Fail detection (motor spinning)

General topics and discussions about the VESC and its development.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
vutana
Posts: 5
Joined: 14 Aug 2018, 05:06
Location: France
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Fail detection (motor spinning)

Postby vutana » 14 Aug 2018, 05:25

Hi all,

I'm trying to get my first VESC working, but I have no success on motor detection. The motor spins three times, and then detection fails.

Here is more info:
* I use VESC Tool on Ubuntu Linux
* Flashed the firmware to last default version provided in VESC Tool
* Hardware is 4.12 (detected 4.10 by VESC Tool)
* Motor is a Velineon 3500kw sensorless from a Traxxas Slash RC car
* I've first tried with the motor mounted on the car. A few times, I've seen the motor accelerating properly in the second detection sequence, and detection worked. But with the detected parameters, the wheels were shaking instead of spinning when I tried to make them rotate. Afterwards, I unmounted the motor. With the motor unmounted (no load except the small gear on the axis), it seems to spin (or sometimes to shake if I put rpm too high), but I've always got a failed detection.
* The VESC is powered by a 3S Lipo, fully charged.
* Cutoff voltage are set to the default (8V - 10V).

I don't know what to try next. Can you help me?

Thanks.

vutana
Posts: 5
Joined: 14 Aug 2018, 05:06
Location: France
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Fail detection (motor spinning)

Postby vutana » 16 Aug 2018, 13:40

Hi,

I've made two videos of the issue:
https://youtu.be/uQFosANFAZU
https://youtu.be/QUz_8-39aqw

In the first video, I did the motor calibration with VESC Tools. After some attempts, and after having downloaded the XML configuration for the Velineon motor from a MIT project which has used the same motor (https://github.com/mit-racecar/hardware ... k_erpm.xml), I have managed to get a motor detection. I've applied the configuration, and uploaded it to the VESC. However, I'm not sure that the behaviour at the end of detection is correct. It is still shaking.

But after that, I still can't spin the motor with the arrow keys (see second video). The motor shakes, but do not spin.

Did I miss something?

Thanks for your help.

erwincoumans
Posts: 25
Joined: 16 Dec 2015, 02:16
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Fail detection (motor spinning)

Postby erwincoumans » 21 Aug 2018, 17:18

I highly recommend adding a sensor to the Velineon motor, and wrote a quick tutorial on how to do it.

See https://docs.google.com/document/d/1cO1 ... o8ac/edit#

vutana
Posts: 5
Joined: 14 Aug 2018, 05:06
Location: France
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Fail detection (motor spinning)

Postby vutana » 21 Aug 2018, 17:36

Hi,

Thanks for your answer and for the tutorial. Do you mean that it is normal that I cannot control the motor sensorless with the vesc? I don't understand why it can run sensorless with the stock esc, and why it couldn't with the vesc.

vutana
Posts: 5
Joined: 14 Aug 2018, 05:06
Location: France
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Fail detection (motor spinning)

Postby vutana » 12 Sep 2018, 07:34

I have finally managed to get my motor running. The first VESC was probably faulty. I have changed it and it works. I manage to control the motor in FOC mode. However, in BLDC mode, I can't get it running smoothly. I still have to find the correct parameters.


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest