Compilation Error

General topics and discussions about the VESC and its development.
Posts: 2
Joined: 25 Jun 2018, 20:11

Compilation Error

Postby ytnoS » 25 Jun 2018, 20:14


I am somewhat new to Linux and attempting to configure the VESC tool with an STM32f0 board, all as specified.

When I run the "make upload" command, after having set conf_general.h to the correct hardware(4.12 in my case), I continually get this error:

Code: Select all

~/BLDC/bldc-firmware$ make upload
openocd -f board/stm32f4discovery.cfg -c "reset_config trst_only combined" -c "program build/BLDC_4_ChibiOS.elf verify reset exit" # For openocd 0.9
Open On-Chip Debugger 0.9.0 (2018-01-22-06:14)
Licensed under GNU GPL v2
For bug reports, read
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 2000 kHz
adapter_nsrst_delay: 100
none separate
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
trst_only combined trst_push_pull
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : clock speed 1800 kHz
Info : STLINK v2 JTAG v25 API v2 SWIM v0 VID 0x0483 PID 0x3748
Info : using stlink api v2
Info : Target voltage: 3.160938
Error: init mode failed (unable to connect to the target)
in procedure 'program'
in procedure 'init' called at file "embedded:startup.tcl", line 473
in procedure 'ocd_bouncer'
** OpenOCD init failed **
shutdown command invoked

Makefile:271: recipe for target 'upload' failed
make: *** [upload] Error 1

Any help at all would be appreciated!

P.S. I have attempted the solutions found here: with no luck.
Update: I have tried the firmware setup on a fresh Ubuntu install -> same exact error

Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.

Re: Compilation Error

Postby rew » 28 Jun 2018, 10:38

ytnoS wrote:with an STM32f0 board, all as specified.
Well, the VESC firmware was written for an STM32F4, so it's never going to work with an F0.
Do you really have an F0?

Posts: 2
Joined: 25 Jun 2018, 20:11

Re: Compilation Error

Postby ytnoS » 28 Jun 2018, 12:48

I suppose so, I just bought a board based on this post:

I ended up fixing this error by changing out my 6 pin cables, and the firmware uploaded fine.

Return to “General”

Who is online

Users browsing this forum: No registered users and 6 guests