VESC makes the cute sound, but motor is only jerking back and forth.

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
amund7
Posts: 9
Joined: 10 Jul 2017, 08:05
Location: Oslo, Norway
Contact:

VESC makes the cute sound, but motor is only jerking back and forth.

Postby amund7 » 23 Dec 2017, 19:15

Setup:

BBSHD
Vesc 4.12
BLDC sensored
Ran fine the whole summer, while duct-taped and cobbeled together
Bought an aluminium casing from ebay, put it in there
afther that, this:

https://youtu.be/SJdSP6hwtLI

You need sound to hear it, but throttle increases cute BLDC noises
Motor only jerks and kind of tugs the chain a bit.
I suspected the hall wires, measured everything, no shorts, no opens. Double checked all other wiring, can't find anything wrong.
Also measured for shorts between phases, nothing

Weirdest thing is this:
If I run the auto-detect sequence, motor spins perfectly!
Tried to switch to sensorless, no change. Through vesc connect pro android app, not sure it stores the settings correctly. It is horrendously buggy.


Any ideas?

ThierryGTLTS
Posts: 80
Joined: 09 Aug 2017, 11:10

Re: VESC makes the cute sound, but motor is only jerking back and forth.

Postby ThierryGTLTS » 24 Dec 2017, 13:04

Did you press apply for the detected parameters and write the configuration to the VESC :?: :!:

No other ideas, if the detection is perfect.

Thierry

TrevM
Posts: 6
Joined: 11 Dec 2017, 20:00
Location: Farnborough

Re: VESC makes the cute sound, but motor is only jerking back and forth.

Postby TrevM » 28 Dec 2017, 23:47

In the video, red LED is flashing 3 times, I think your DRV8302 is blown

amund7
Posts: 9
Joined: 10 Jul 2017, 08:05
Location: Oslo, Norway
Contact:

Re: VESC makes the cute sound, but motor is only jerking back and forth.

Postby amund7 » 02 Jan 2018, 13:53

If you mean the red led on top of the bike frame, that's a BLE UART chip. But I didn't think about that the VESC may be trying to tell me something. There are some red and blue flashes as it boots up, and gradual white as I push the throttle.

Can you tell me / do you have a link to what these blinks mean? I just googled it, and what I found (in esk8 forum) says that three blinks means everything is good...

Keep in mind that this bike was running fine until I basically put the VESC in a case (means I unplugged & replugged the wires). Hope that can't blow the DRV chip...


Return to “Hardware Problems”

Who is online

Users browsing this forum: Google [Bot] and 2 guests