Turnigy SK3 6374 149 motor

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
TrevM
Posts: 6
Joined: 11 Dec 2017, 20:00
Location: Farnborough

Turnigy SK3 6374 149 motor

Postby TrevM » 13 Dec 2017, 20:22

I have a self built VESC 4.12 with 3.34 Firmware, Haiyin 5000mAh 20-30C battery, Turnigy SK3 6374 149 motor.
I can't get the BLDC Tool Motor Setup Wizard to complete.

Please can anyone supply a set of BLDC Parameters that may work?
I'm looking for I, w, D values that will work for this motor.

BLDC mode, I always get Detection failed, tried a few different values.
FOC mode, RL stage completes:
R: 13210.19 mOhms L: 23.11 uH
Motor spec says 0.021 Ohm internal resistance, so calculation seems to be wrong.

Please help

ThierryGTLTS
Posts: 86
Joined: 09 Aug 2017, 11:10

Re: Turnigy SK3 6374 149 motor

Postby ThierryGTLTS » 14 Dec 2017, 08:43

If you have access to a LCR meter, please test R and L (phase to phase) with it to confirm manufacturers values.

A small difference can be acceptable.

But test your motor at least with a Power Supply (current limited to about 1Amp for example) and a simple multimeter to be sure you have about the same value between all the phases.

Have a Nice Day.

Thierry

pf26
Posts: 309
Joined: 28 Mar 2016, 14:37
Location: FR Valence

Re: Turnigy SK3 6374 149 motor

Postby pf26 » 14 Dec 2017, 09:37

With SK6374 149kV, I found:
R 0.0176 Ohms, L:20.87uH Lambda: 0.00496 Gain 47.92

Addy
Posts: 7
Joined: 10 Aug 2017, 17:56
Location: BC, Canada

Re: Turnigy SK3 6374 149 motor

Postby Addy » 14 Dec 2017, 19:52

I use this motor with V4.12 VESCs that I assembled. Normally the detection works fine.

One time I could not get detection to work and the resistance reading was quite high, like yours. The problem for me was that the DRV chip was broken. Two of the mosfets were not being driven. I checked with an oscilloscope on the DRV chip - the signals for the mosfets looked fine on the input of the DRV, but 2 of the outputs did nothing. Replacing the DRV solved the problem and detection was working again.

TrevM
Posts: 6
Joined: 11 Dec 2017, 20:00
Location: Farnborough

Re: Turnigy SK3 6374 149 motor

Postby TrevM » 19 Dec 2017, 16:55

Thanks guys, I will be re-trying, but having to make a new VESC.
For full details, see:
http://trevmhomers.blogspot.co.uk/
My own blog, not a money making thing, earned £1.58 in last 2 years, but easier to put photos on.

TrevM
Posts: 6
Joined: 11 Dec 2017, 20:00
Location: Farnborough

Re: Turnigy SK3 6374 149 motor

Postby TrevM » 24 Dec 2017, 17:13

Thank you Benjamin and all, I now have a fully working motor, battery and VESC :D
All I have to do now is mount it to a 66 year old bicycle, how hard can that be?


Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 2 guests