making custom hardware

Discuss hardware related to the VESC such as the NRF nunchuk.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
vyckakk
Posts: 5
Joined: 20 Oct 2016, 10:44
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

making custom hardware

Postby vyckakk » 13 Mar 2017, 11:08

Hello,
I making custom hardware of vesc. I put firmware to stm32f407 discovery board. Also changed drv8302 to hcpl-3120 optocoupler. maked voltage and current measurement schemes. And connected like showed in BLDC.pdf file.
Problem - when I trying to move motor, it starts to move and give fault code- under_voltage. In real time monitor battery voltage shows good. But, then write in terminal faults, it prints voltage 0.
Maybe someone have idea what problem it is?

vyckakk
Posts: 5
Joined: 20 Oct 2016, 10:44
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: making custom hardware

Postby vyckakk » 13 Mar 2017, 14:13

Here is my wiring scheme without current amplifier:
Untitled2.png
Untitled2.png (42.52 KiB) Viewed 2384 times

Untitled.png
Untitled.png (35.78 KiB) Viewed 2384 times

Untitled1.png
Untitled1.png (36.61 KiB) Viewed 2384 times

User avatar
TheFallen
Posts: 84
Joined: 26 Oct 2016, 10:49
Location: UK
Contact:

Re: making custom hardware

Postby TheFallen » 13 Mar 2017, 14:32

From the pictures it looks okay. You've got 39kOhm and 2.2kOhm resistors in the right places, so assuming you've got things connected up correctly to your logic board there shouldn't be any problems there.

Why are you using an STM32F407? Not an STM32F405?

What voltage is the under voltage threshold set to? And what voltage are you supply? It'd be great to get a few pictures of your test setup.

rew
Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: making custom hardware

Postby rew » 13 Mar 2017, 20:50


pf26
Posts: 310
Joined: 28 Mar 2016, 14:37
Location: FR Valence
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: making custom hardware

Postby pf26 » 14 Mar 2017, 08:55

Unrelated to your voltage fault issue, I find it strange the way the capacitors C5 and C9 are connected. I think their negative pin should go to GND instead of the shunt. With low esr capacitors, you may have unwanted current flowing there.

vyckakk
Posts: 5
Joined: 20 Oct 2016, 10:44
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: making custom hardware

Postby vyckakk » 14 Mar 2017, 17:31

Today I found one more thing about HIGH2 signal: H2 connection or PA9 pin on stm board didnt give signal and it is high(5V), because this pin is using as USB VBUS pin or as I/O pin PA9. When I connected to computer, computer USB gives 5V. Now I disconnect this pin from USB port.
After that, I tried to spin motor and it was same thing - Under_voltage. And found third transistor (H2 signal transistor) - burned, it makes open circuit.

Tomorow i will try to change transistor and make some measurments.

Here are configuration and plots.

2.png
2.png (25.17 KiB) Viewed 2351 times

Under_voltage.png
Under_voltage.png (49.01 KiB) Viewed 2351 times

BEF.png
BEF.png (44.28 KiB) Viewed 2351 times

dkmorb
Posts: 2
Joined: 24 Apr 2017, 06:49
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: making custom hardware

Postby dkmorb » 24 Apr 2017, 06:54

May be you have to use PE11 instead of PA9
Bye.


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Return to “Related Hardware”

Who is online

Users browsing this forum: No registered users and 0 guests