Questions about hall sensors

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
Quezacotl
Posts: 24
Joined: 05 Apr 2017, 11:06
Location: Finland
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Questions about hall sensors

Postby Quezacotl » 03 May 2017, 15:50

Hello!

Can anyone tell, do i need to arrange the three hall sensor wires in right order? Or can they be in any order?

I'm having an issue that VESC doesn't detect my hall sensors...

EDIT: Now when i measured, they all give low, and doesn't change at all when i rotate the wheel. They can't be all broken, so what could be the problem?
I confirmed that they are 5V sensors, since the previous controller supplies 5V to the sensors.

I have a no name 250W bike hub motor, that had previously chinese controller, and the hall sensors did work.
I have hooked them up directly to the sensor pins on the VESC board. No pullups etc.

EDIT: Apparently they all can be broken, or 5v or GND could be snapped inside the shaft or something. I don't have any good tools to open the motor, so i'll just leave it as sensorless.

rew
Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Questions about hall sensors

Postby rew » 05 May 2017, 15:12

There ARE sensors that require a pullup.


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 3 guests