Only blue LED after ground short

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
Pedrodemio
Posts: 14
Joined: 02 Jan 2016, 19:35
Location: Brazil
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Only blue LED after ground short

Postby Pedrodemio » 06 Apr 2017, 22:12

So, i was happily diagnosing my system, a VESC + Arduíno with NRF radio, i had just found out the problem, had everything off when disaster happened

I touched the Arduíno USB carcass and the battery input of the Antispark switch together with the oscilloscope probe, basically i powered the system on but the ground path was trough the Arduíno ground that was connected via UART to the VESC

After that only the blue led lights up, apparently nothing overheat, but obviously the STM is not booting up, can i assume i killed it? or is some mysterious way only the firmware got erased and i have to flash it again?

Thanks for any help

Edit: the Arduíno is dead for good, on the PC it cycles between power on and off, i assume over current protection, and on a USB charger it does nothing, but since is cheap, i don't care, what worries me is the VESC, since i'm outside US with import taxes and shipping a VESC is very expensive, i have one that i can use for now that was destined for my future dual build

rew
Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Only blue LED after ground short

Postby rew » 07 Apr 2017, 09:07

yeah. the STM will die and never boot again when you apply high voltages on its pins. I connected the motor voltage once where the voltage divider for measuring battery voltage was supposed to go. Exit one STM. No visible damage.

Pedrodemio
Posts: 14
Joined: 02 Jan 2016, 19:35
Location: Brazil
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Only blue LED after ground short

Postby Pedrodemio » 07 Apr 2017, 10:53

Thanks rew, I will start diagnosing latter today to see if at least if is being fed, but the thing is, there wasn't high voltage involved, but the whole system got powered on via the signal ground

rew
Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Only blue LED after ground short

Postby rew » 08 Apr 2017, 13:27

You say you connected the battery input of the anti spark and the ground on the arduino. That may appy -<bat voltage> to a bunch of pins that remained connected to the battery minus.

If you disconnect everything from your battery and then ONLY touch the VESC-ground to the positive of the battery, that's perfectlky safe. You say SOMETHING happened. If you know enough to prevent it from happening again, then that's a lesson learned. I fried mine by plugging in a connector off-by-one. I know what caused it, and I'll try not doing that again.


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 2 guests