cut off when full throttle

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
sch_ch1
Posts: 6
Joined: 15 Aug 2016, 00:54
Location: Vienna
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

cut off when full throttle

Postby sch_ch1 » 15 Aug 2016, 01:09

hey guys

first of all, please dont mind my english as Im from austria and its not my mother language... I registered here cause I dont get any help in the german forum Im usually using.

I just changed my setup from 6S to 9S and from a standard ppm remote to a kama nunchuk, my VESC is running in FOC as it was with 6S.
On my testride after the named changes I noticed that there is a motor cut off when Im acceleratin at full throttle. It happened about 90% every time I tried but I didnt try very often since its scary and dangerous when your leaning foreward for acceleration and the acceleration suddenly stops when you press the throttle to max.

It no matter of speed and doesnt matter if Im pressing throttle gently or hard, but when it comes to full throttle (no matter if I just started accelerating and pressing to the max or if I accelerate slowly and then try pressing to the max), the VESC cuts off power and the acceleration stops.

I dont think its a problem of the nunchuk but caused by the 9S I guess. It doesnt happen if i turn the board around wheels spinning free, but happens under load when Im riding.

hope anyone got an idea what parameters I could change to fix that.

greez chris

rew
Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby rew » 15 Aug 2016, 07:05

Maybe it's hitting "max battery current"?

pf26
Posts: 310
Joined: 28 Mar 2016, 14:37
Location: FR Valence
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby pf26 » 15 Aug 2016, 09:56

You can display the last recorded errors in BLDCTools/Terminal, by typing the command: faults
You should keep your VESC constantly powered between failure and connection to your PC/BLDCTools.

sch_ch1
Posts: 6
Joined: 15 Aug 2016, 00:54
Location: Vienna
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby sch_ch1 » 15 Aug 2016, 19:28

thanks for your suggestions! I tested again today and then made a screenshot with the abs fault code. I don't know what most of the parameters are meaning, but I guess someone of you does... :)

vesc fault.jpg
vesc fault.jpg (192.13 KiB) Viewed 5161 times

rew
Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby rew » 16 Aug 2016, 06:38

Think of the motor as a merry-go-round.
Image
Now instead of a motor in the middle, you sit by the side and push each of the seats as it goes by. You can make the thing go round, right? Now imagine this merry-go-round having 7 seats along the perimeter, but... instead of them being spaced equally, they stagger a little bit. So if you prepare to push the approaching seat, sometimes the seat is a bit further or backward compared to where you expected it. So sometimes you first push a bit of air, and then hit the back of the seat, other times, the seat is further back and you hit harder than you wanted.

This is what happens with the RC Hobby motors. They vary a bit along the perimeter, and some of the pushes from the ESC are a bit more firm than others. This results in current peaks, so, you need to set an "absolute maximum current" of 1.5 to 2x the max continuous current. Otherwise.... you know what happens. Show us your "motor configuration" tab.

sch_ch1
Posts: 6
Joined: 15 Aug 2016, 00:54
Location: Vienna
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby sch_ch1 » 16 Aug 2016, 16:17

ok I guess I know what you're trying to explain and I instantly thought about my "modification" to make the motor splashproof:

I put a part of some tights over the open side of the motor and fixed it with a wire tie... I guess the wire tie could cause the motor to run uneven at higher speed... I'll post a picture of my "construction" so you can judge. IF thats the problem, I think it simply would be fixed if Id put another wire tie with its big ending exactly to the opposite side to counterbalance the momentum... so far in theory, but I'll wait for your suggestions
thumbnail_IMG_20160816_181517.jpg
thumbnail_IMG_20160816_181517.jpg (165.42 KiB) Viewed 5137 times


I also got a screen of my motor configuration - the absolute maximum current is set to 130A so I guess thats not the problem causing my fault?!
motor config.jpg
motor config.jpg (293.08 KiB) Viewed 5137 times



thanks for everybodys effort

edit:
I forgot to post the details of the motor I'm using.. again^^ so here it is
6360 bldc, 210kv, and here's the link:
https://www.lindinger.at/at/flugzeuge/a ... less-motor

rew
Posts: 943
Joined: 25 Mar 2016, 12:29
Location: Delft, Netherlands.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby rew » 16 Aug 2016, 19:56

It is the inaccuracy of the motor construction that causes the unevenness of the full rotation. 130A looks as if it's enough. Oh.... how big and where are your capacitors?

sch_ch1
Posts: 6
Joined: 15 Aug 2016, 00:54
Location: Vienna
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby sch_ch1 » 16 Aug 2016, 20:29

alright, then Im going to fix that and test tomorrow if the weather is ok. :) didn't think about that to cause the fault on my vesc...

as to the capacitors, Im using the latest version of the vesc - couldnt find the details you asked for, but if you dont allready know by mentioning the latest vesc version, you can look up the description on http://esk8.de/ but like I said, I couldnt find the values but maybe the pictures will help too

david
Posts: 36
Joined: 15 Dec 2015, 13:19
Location: Hamburg, Germany
Contact:

Re: cut off when full throttle

Postby david » 16 Aug 2016, 22:34

Those are 3x Nichicon 680mF 63V.

How long are your cables between VESC and battery in total? Or did you put a longer cable between VESC and capPCB?
VESCs made in Germany

artteth
Posts: 28
Joined: 22 Jul 2016, 00:28
Location: Belarus
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: cut off when full throttle

Postby artteth » 17 Aug 2016, 02:53

do you have same problem in bldc mode?


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 1 guest