Another fried 4.12 VESC.

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
erod998
Posts: 1
Joined: 27 Aug 2018, 19:10
Location: Tennessee
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Another fried 4.12 VESC.

Postby erod998 » 27 Aug 2018, 19:19

Hey all,
Using my second ever VESC on my first build. Had to buy another because I blew up a mosfet and after trying to replace it and the DRV just gave up when it didn't turn on after my attempt. Anyways, was about 10 miles in to this ride on the new VESC when the DRV blew. Pretty sure I diagnosed why thanks to the help of those at the ESK8 forum. Using a 12s4p, I had the batt max set to 70 amps. Whoops, apparently my particularly VESC is only safe within 50-60.
Ok, not a big deal, if it was just the DRV I had two from the previous attempt. Hot air'd a new one on. Turned it on, and got nothing. No lights at all. Noticed I had a short on two pins, fixed and tried again. Again, nothing. Felt the board and the diode (D5) was very hot. Replaced it, and turned back on. The blue light came on for a second or two, then went off and again the diode and DRV was hot. Not sure how warm the DRV is supposed to get, but it felt significantly warmer than anything else besides the diode.

Any recommendations on to which parts I should check and replace? Another piece of info, this DRV was taken off the old VESC that I gave up on, so it is possible that it was damaged then sequentially damaged a part on my new VESC. I am going through to check all resistors and diodes, but I am slightly scared to turn the board on to see if I have 3v3 or 5v with those two components getting warm. Attached is the old blown DRV so everyone can laugh, and also the "new" one.

Currently, D5 and D4 both are reading .12 volts in both directions on my multimeter in diode test mode.
Both sides of D5 have continuity to ground. On D4, only cathode of course.
I think the problem is with D5. It is shorted. I have 5v and GND from the servo pins connected somehow. I have another diode from the old vesc that is working it looks like, I can replace the diode without having to wait for a new one, but it will short again since something else is wrong on the board. Just powered the board on. The D5 diode got so hot it unsoldered itself. Then I had life in the board....the blue and green lights came on. Can I run the VESC without D5?

UPDATE: Got it all working but in my haste/tiredness accidentally connected the VESC backwards, now there is no resistance between the positive and negative. Anyway to fix a VESC damaged by reverse polarity? What parts possibly got damaged? Is the DRV the only chip connected to the battery?
Attachments
IMG_6150 copy 2.jpg
IMG_6150 copy 2.jpg (926.79 KiB) Viewed 3236 times
IMG_9939 copy.jpg
IMG_9939 copy.jpg (979.62 KiB) Viewed 3239 times
IMG_3396 copy.jpg
IMG_3396 copy.jpg (845.14 KiB) Viewed 3241 times

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 1 guest