[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 594: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 650: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 1110: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 1110: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 1110: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5277: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5277: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5277: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
vedder.se forums • 3.3V Problems with VESC hw4.12
Page 1 of 1

3.3V Problems with VESC hw4.12

Posted: 19 May 2018, 18:31
by simonzwanzig
I have a VESC hw version 4.12.
I have already flashed it with the newest software version
My Problem is that the VESC only connects via USB if the St link programmer is still plugged in and supplying it with 3.3 Volts.
Obviously it doesn't drive my motor that way.
I have already changed out my DRV 8302 chip because the software said thats the fault but that doesn't solve the issue.
So how could I get the VESC to work properly ?

Thanks in advance
Simon

Re: 3.3V Problems with VESC hw4.12

Posted: 20 May 2018, 11:28
by arvidb
With your VESC powered only by motor power, what are the voltages over C33 and C25 (the bypass caps for the 5 V and 3.3 V rails)?

Re: 3.3V Problems with VESC hw4.12

Posted: 21 May 2018, 11:13
by simonzwanzig
I get 0V across both of them

Re: 3.3V Problems with VESC hw4.12

Posted: 22 May 2018, 05:17
by rew
Well... the DRV should be functioning as a switching regulator to make 5V. If that doesn't happen, the DRV is broken, or somehow not correctly connected.

Can you measure a short between the 5V and GND? There is a zener that tries to keep 5V at "near 5V" levels when the DRV misbehaves and tries to increase the voltage at the 5V rail beyond 5V.

That zener could short if the DRV is powerful enough. Oh, and the DRV "misbehaves" when you forget to connect it's ground pin. You're not the first to forget that.

Re: 3.3V Problems with VESC hw4.12

Posted: 22 May 2018, 10:59
by arvidb
Also check the (soldering of the) other components involved in the 5 V supply: U3, L1, R17, R18, R19, C19, C21, C27 and C39 on the DRV side, and D4, C33, R21 and D5 on the other side. Did you mount D4 with correct polarity, for example?