Problems with VESC 6 and VESC TOOL V0.87

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
JL2579
Posts: 2
Joined: 11 Jan 2018, 13:49
Location: Germany
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Problems with VESC 6 and VESC TOOL V0.87

Postby JL2579 » 11 Jan 2018, 14:10

Hi Guys,
I have discovered the vesc a few months ago and after several failed attempts of soldering my own vesc 4.12 I bought a vesc 6 for my own ebike project, which was finished a few days ago. ( In case anyone wants to see a few pics/specs, I will make a seperate post, unfortunately I am away from the bike for the next few months now and only have very few pictures).

During the project I had to fight with several issues of the vesc and wanted to post them here so they might get fixed or people tell me other workarounds:

-the whole vesc tool layout isn't made for high DPI screens at all. ( maybe there is a setting, but I didn't find it and all the buttons are extremely tiny on my laptop)

- it took me 20 mins to find the keyboard control button. Maybe add one tab to the left for newbies, maybe its just related to the previous issue

- the keyboard control doesn't work at all. My VESC works and both the calibrating of the motor and the thumb throttle works, but keyboard control is only making some noise in the motor. I assume this is due to too low current, but the keyboard control current seems to be not adjustable anywhere ?!

-At one point I had the issue of the vesc locking at full throttle unless some external mechanical brake was applied. After plenty of testing I figured out that this was because I had set the deadband too narrow and the motor wirings were inducing enough voltage into the throttle wire that was partially parallel to keep on spinning at full speed !!. Rewiring , limiting the duty cycle and increasing the deadband did fix it for me, but there is always a serious amount of induced voltage in the throttle wire at full speed no matter how I hold the cable, which leads me to the assumption that the rest happens directly at the port on the board, which is a serious design flaw at the port IMO. Try it yourself, at 95% duty cycle with a turnigy 6374 192KV the ADC1 Voltage alternates at several hertz by about 10% or more. the problem drastically increases with increasing duty cycle, but is even at the default 95% very present.

-when accelerating and hitting the duty cycle limit, there is a very hard cutoff that feels like hitting the rev limiter on a car in a low gear. Maybe include an option for soft current cutoff at duty cycle limit ( or is there one and I didn't find it yet, if so I am sorry).

-I whish I was able to display all data in the real time analysis at once and not have to switch between tabs.

Looking forward to your replies,
JL2579

ThierryGTLTS
Posts: 86
Joined: 09 Aug 2017, 11:10
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Problems with VESC 6 and VESC TOOL V0.87

Postby ThierryGTLTS » 11 Jan 2018, 17:53

Hi,

Have you read this :?: :!:

Thierry

JL2579
Posts: 2
Joined: 11 Jan 2018, 13:49
Location: Germany
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Re: Problems with VESC 6 and VESC TOOL V0.87

Postby JL2579 » 12 Jan 2018, 12:41

Surely I have read them, and none of the mentioned issues I above is addressed there.


[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1236: count(): Parameter must be an array or an object that implements Countable

Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 1 guest