Page 1 of 1

VESC makes the cute sound, but motor is only jerking back and forth.

Posted: 23 Dec 2017, 19:15
by amund7

Vesc 4.12
BLDC sensored
Ran fine the whole summer, while duct-taped and cobbeled together
Bought an aluminium casing from ebay, put it in there
afther that, this:

You need sound to hear it, but throttle increases cute BLDC noises
Motor only jerks and kind of tugs the chain a bit.
I suspected the hall wires, measured everything, no shorts, no opens. Double checked all other wiring, can't find anything wrong.
Also measured for shorts between phases, nothing

Weirdest thing is this:
If I run the auto-detect sequence, motor spins perfectly!
Tried to switch to sensorless, no change. Through vesc connect pro android app, not sure it stores the settings correctly. It is horrendously buggy.

Any ideas?

Re: VESC makes the cute sound, but motor is only jerking back and forth.

Posted: 24 Dec 2017, 13:04
by ThierryGTLTS
Did you press apply for the detected parameters and write the configuration to the VESC :?: :!:

No other ideas, if the detection is perfect.


Re: VESC makes the cute sound, but motor is only jerking back and forth.

Posted: 28 Dec 2017, 23:47
by TrevM
In the video, red LED is flashing 3 times, I think your DRV8302 is blown

Re: VESC makes the cute sound, but motor is only jerking back and forth.

Posted: 02 Jan 2018, 13:53
by amund7
If you mean the red led on top of the bike frame, that's a BLE UART chip. But I didn't think about that the VESC may be trying to tell me something. There are some red and blue flashes as it boots up, and gradual white as I push the throttle.

Can you tell me / do you have a link to what these blinks mean? I just googled it, and what I found (in esk8 forum) says that three blinks means everything is good...

Keep in mind that this bike was running fine until I basically put the VESC in a case (means I unplugged & replugged the wires). Hope that can't blow the DRV chip...

Re: VESC makes the cute sound, but motor is only jerking back and forth.

Posted: 24 Jan 2018, 19:21
by amund7
Measured hall sensors and wires again, all give pretty much equal ohms, wires are good, connections correct
Measured motor phases, equal ohms, connections good
USB plug is broken (my fault) Tried to solder on a new one, but failed (too tiny, cant solder it properly)
Tried BLE connection from Windows with VESC Tool: Debug text says "platform not supported"
Tried BLE connection from Android VESC Tool: Super buggy, detects BLE chip, but will not connect
Tried BLE connection from Android/Vesc PRO app: Super buggy, randomly says 'BLE device detected', 'connected' and 'not connected'. Sometimes I manage to connect, read settings, detect motor parameters and even run the detection sequence! Motor spins fine, detects hall sensors. But write does not seem to work, it says it does, but the settings arent sticking, and throttle input sends us back to zero (i.e. cute sounds, jerky, no rotation)
Tried VESC Tool for Linux on my Raspberry pi 3, hoping it might support BLE, since windows does not (QT does NOT support BLE on windows at all!) Result: Error in binary format (probably does not support ARM cpu?)
Probably means to install the whole QT system + compiler on the Raspberry. I tried that before, and pretty much came to the conclusion that QT is bigger than any SD card you can buy :)
Tried setting up cross compiling for QT, that was a 2 week project, then I swapped out my PC hard drive and now it's all gone. Not doing it again!
And if I did, I can guarantee you it's the wrong version of QT to compile the VESC tool.

This is my second VESC, first one blew up when detecting FOC settings.
I am debating buying a FOCBOX instead, but unsure if that will give me the sweet FOC with proper cooling I always dreamed about, or the same hell on earth as the two previous ones, just that this third one will cost more than the two old ones combined.

After reading through this I wonder how I get myself into these things. And how is it possible after three platforms, four computers, 2 phones and what 12 combinations of platforms, apps and software NONE OF THEM WORK?
And all of this to fix a problem that by all logic and reason does not exist.