4.12 "The firmware on the connected VESC is too old"

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
zhud
Posts: 2
Joined: 19 Nov 2017, 12:40
Location: US

4.12 "The firmware on the connected VESC is too old"

Postby zhud » 19 Nov 2017, 12:47

"Please update it using a programmer."

Did the steps provided for setting up Ubuntu and BLDC Tool. Everything works as it should except for when the VESC connects to the BLDC Tool (2.17,2.18).

One of the things that I ran into that didn't work on the install was the "sudo reload udev" command, but I think I managed achieve the same with another command.

I an using Ubuntu 16.04.

I am using the ST-Link V2 USB.

I have tried to do so many things to try to make this work, I am at a loss now. I don't know what I can do at this point. Any help would be very appreciated . Thank you.

TrevM
Posts: 6
Joined: 11 Dec 2017, 20:00
Location: Farnborough

Re: 4.12 "The firmware on the connected VESC is too old"

Postby TrevM » 11 Dec 2017, 20:08

The VESC instructions no longer work.
The bootloader is fine, it hasn't been changed in 3 years.
The main firmware is the problem, Benjamin has been updating it to handle his new V6.00 hardware, current firmware as fetched by instructions is V3.32.
Now run up BLDC_Tool and look at firmware tab, it supports 2.17 and 2.18.
The firmware is actually too NEW for the BLDC_Tool, it doesn't know how to handle 3.32, so gives message that firmware in unit is too old!
I used Git to set a branch at FW 2.18, then instructions work.

This doesn't mean mine is fully working yet, I still have to connect up to motor and try to configure it.

ThierryGTLTS
Posts: 80
Joined: 09 Aug 2017, 11:10

Re: 4.12 "The firmware on the connected VESC is too old"

Postby ThierryGTLTS » 12 Dec 2017, 09:50

After Firmware 2.18 use VESC Tool instead of BLDC Tool.

Works fine and even allows you to go back to V2.18 to use BLDC Tool again :!:

Thierry


Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 1 guest