Problems flashing

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
rmb54
Posts: 1
Joined: 07 Jul 2018, 18:25
Location: Pensacola

Problems flashing

Postby rmb54 » 07 Jul 2018, 18:38

I am using a vesc 4.12 that I bought from Maytech and both firmware and bootloader are old so I cannot use the bldc-tool. I have a ST-LINK V2 and I am powering my VESC with a 4s Lipo battery, since I do not have a power supply.

Image

When I run the make upload command I get this error:

Code: Select all

openocd -f board/stm32f4discovery.cfg -c "reset_config trst_only combined" -c "program build/BLDC_4_ChibiOS.elf verify reset exit" # For openocd 0.9
Open On-Chip Debugger 0.9.0 (2018-01-24-01:05)
Licensed under GNU GPL v2
For bug reports, read
   http://openocd.org/doc/doxygen/bugs.html
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 2000 kHz
adapter_nsrst_delay: 100
none separate
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
trst_only combined trst_push_pull
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : clock speed 1800 kHz
Info : STLINK v2 JTAG v29 API v2 SWIM v7 VID 0x0483 PID 0x3748
Info : using stlink api v2
Info : Target voltage: 1.528413
Error: init mode failed (unable to connect to the target)
in procedure 'program'
in procedure 'init' called at file "embedded:startup.tcl", line 473
in procedure 'ocd_bouncer'
** OpenOCD init failed **
shutdown command invoked

Makefile:271: recipe for target 'upload' failed
make: *** [upload] Error 1


I wish someone could help me to clarify whats wrong. I also tried on windows to use the STM32 ST-LINK utility and it did not work. gives me USB error.
I am really lost here

User avatar
TheFallen
Posts: 83
Joined: 26 Oct 2016, 10:49
Location: UK
Contact:

Re: Problems flashing

Postby TheFallen » 09 Jul 2018, 15:55

You're not powering the STM32F405.

The critical line is:

Code: Select all

Info : Target voltage: 1.528413


The STMLink is seeing +1.53V on the +3V3 rail. That's not going to work.


Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 1 guest