Vesc6 GVDD under voltage fault.

Report your hardware problems here. Include as many details as possible with pictures to get the best possible help and feedback.
district9prawn
Posts: 4
Joined: 08 Apr 2018, 10:40
Location: Sydney

Vesc6 GVDD under voltage fault.

Postby district9prawn » 15 May 2018, 15:35

Hi all,

I finished soldering my vesc 6 and was able to power up and flash firmware successfully as well as stream RT data in vesc tool. When I tried bldc auto detect, I got GVDD error immediately. When trying RL detect in FOC, the motor buzzed very briefly and I got the same error.

Code: Select all

Fault            : FAULT_CODE_DRV
Current          : 0.6
Current filtered : 0.0
Voltage          : 23.41
Duty             : 0.009
RPM              : 0.2
Tacho            : 3
Cycles running   : 2
TIM duty         : 432
TIM val samp     : 216
TIM current samp : 25547
TIM top          : 50663
Comm step        : 1
Temperature      : 33.73
DRV8301_FAULTS   : | GVDD_UV | FAULT |


My GVDD pin is still giving 12v so hopefully drv isnt dead. I've started measuring the fets as there is no way to inspect the solder joint at the gate and source. Drain source test seems to check out (infinite resistance one direction and diode the other way). Gate to ground resistance is near infinite except on one low side fet the gate resistance is about 35k ?!

Duo420
Posts: 3
Joined: 09 May 2018, 20:08

Re: Vesc6 GVDD under voltage fault.

Postby Duo420 » 17 May 2018, 18:11

Hello, I new to VESC I my vesc is not working right now but to my mind you fried the mosfets somehow. Looking at the schematic the resistance from the lower fets of the ground to the gate should be 35k as there is a resistor there. I could be wrong but do you know how to test the fets with the multimeter. As the gates of the low side are connected to gnd trought the resistor after charging the gate the mosfet should let current trough and then close as the gate discharges trough the resistor.
Attachments
Schematic-2.png
Schematic-2.png (165.98 KiB) Viewed 321 times

district9prawn
Posts: 4
Joined: 08 Apr 2018, 10:40
Location: Sydney

Re: Vesc6 GVDD under voltage fault.

Postby district9prawn » 18 May 2018, 04:27

The fets checked out fine and it ended up being the drv. No idea how but replacing it did the trick.

Ah the drv....

district9prawn
Posts: 4
Joined: 08 Apr 2018, 10:40
Location: Sydney

Re: Vesc6 GVDD under voltage fault.

Postby district9prawn » 05 Jun 2018, 12:39

I was having this same problem on another HW6 board I was soldering. In this case it turned out that some solder mask had peeled back on the DRV ground pad and the tinned area of ground pad extended all the way up to some pins, shorting gate drive to ground. At least it was able to be fixed with reflow only with no need to remove the DRV.


Return to “Hardware Problems”

Who is online

Users browsing this forum: No registered users and 1 guest