Communication with VESC is limited - cant get results from hall detection, etc.

General topics and discussions about the VESC and its development.
Jackl
Posts: 10
Joined: 12 Mar 2017, 22:23

Communication with VESC is limited - cant get results from hall detection, etc.

Postby Jackl » 14 Jun 2017, 16:18

Hi Everyone!

I am using a VESC in a custom scooter. Setup is as follows:
- VESC for Motor Control
- 12N14P Outrunner with custom hall sensors and skewed magnets
- 12S 18650 Battery
- Commands to VESC via UART

Now I want to switch from BLDC mode to FOC in order to improve handling and reduce noise, etc.
At first, this worked quite well. I ran through the full procedure with measuring R, L, etc. and detecting the Hall Sensors via BLDC Tool. Wheel/Motor turned smoothly, both with BLDC Tool commands and UART commands.

I then wanted to change some settings and now the motor is not spinning any more.

Symptoms:
- I can not get the motor to work, neither from UART commands, nor with BLDC Tool commands via the arrow keys. I only get a small clicking noise and around 200mA of motor current.
- I can still read and write setting to the VESC via BLDC Tool
- I can still start the hall sensor detection in FOC, works like a charm!
- I get NO RESULTS from Hall detection, neither in FOC nor in BLDC mode. It just says "Detection results will be printed here" in BLDC, and just stays at zeroes in FOC mode.

What could be the reason for that?
Cheers and thanks!

Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests