Found more MCUs VESC is broken on

General topics and discussions about the VESC and its development.
Posts: 171
Joined: 19 Jan 2016, 10:54
Location: Australia

Found more MCUs VESC is broken on

Postby lizardmech » 21 Sep 2016, 12:55

I built my own little MCU modules using STM32F405 64lqfp, MCUs were from mouser, the same problem I found with recent discovery boards is present but behaves slightly differently. Openocd cannot flash them, VESC firmware will work if flashed in windows using the official ST-link software. A new issue I found is while BLDC tool appears able to write configurations it cannot update it's firmware any more. The biggest issue is if you try to flash it via BLDC tool it claims it worked, however nothing is actually erased or written, I only discovered it because I have a different voltage divider, I flashed stock firmware in windows and was then using BLDC tool in linux to flash custom firmware, I kept getting incorrect voltage readings. After hours trying to find a hardware fault I just connected 3.3v to the MCU ADC only to have it report 61V as in the stock firmware. Despite BLDC tool claiming to have flashed it 5 or 6 times it was still on the initial firmware I flashed via ST-link software.

I flashed it again in windows with my custom firmware and it changed the voltage reading to 89.1V @ 3.3v AN_IN as expected. I'm still not 100% if it's my openocd install on linux or a MCU revision that changed something to do with writing flash memory.

Return to “General”

Who is online

Users browsing this forum: No registered users and 7 guests