MadCatz Nunchuk solution

Are there any features that you would like to add to the VESC?
barney
Posts: 22
Joined: 23 Dec 2015, 08:21

Re: MadCatz Nunchuk solution

Postby barney » 07 Feb 2016, 11:24

DeathCookies wrote:I am sorry, is this code a complete file or do i need to add it in any specific file?
Does it work with the MadCatz Nunchuk?


This file is for an Teensy 3.1 Mircocontroller, not for ST!

This additional line is needed for MadCatz

Code: Select all

// crypto key data address
Nunchuk::_sendByte(0x40, 0x00);


Ask Benjamin for implementation.

Barney

benjamin
Site Admin
Posts: 280
Joined: 15 Dec 2015, 08:38
Location: Sweden
Contact:

Re: MadCatz Nunchuk solution

Postby benjamin » 09 Feb 2016, 16:56

I don't know if it is that simple. I have another nunchuk that looks very similar to the madcatz at home that I got from dealextreme some time ago, and I only got it working with very low update rate for some reason. The used madcatz nunchuk that I bought from ebay does not seem to work at all even when I experiment with the code, but it could be broken. Before I make changes to the code I would like to confirm that they work properly first, an right now I don't have any way to do that.

DeathCookies
Posts: 4
Joined: 06 Feb 2016, 18:25
Location: germany

Re: MadCatz Nunchuk solution

Postby DeathCookies » 09 Feb 2016, 18:24

I am waiting on my vesc and madcatz nunchuk but it will arrive within the next 2 weeks. Maybe you can send me some sample codes and i can test it.
PS: do i need for foc the latest version or does 4.10 work?

DeathCookies
Posts: 4
Joined: 06 Feb 2016, 18:25
Location: germany

Re: MadCatz Nunchuk solution

Postby DeathCookies » 11 Feb 2016, 09:03

I just found this thread, maybe it helps

http://forum.arduino.cc/index.php?topic=22056.150

njakts
Posts: 6
Joined: 01 Jul 2016, 07:14
Location: LV

Re: MadCatz Nunchuk solution

Postby njakts » 04 Jul 2016, 06:54

I tested my MadCatz nunchuk yesterday and the test failed.

Nunchuk wont stay connected to receiver once its connected to vesc. it works first 1-2 seconds after vesc is started, then blue light on receiver goes out and vecs stays in last given state - if I apply throttle and signal is lost - vesc keeps the throttle until reboot..

I tested my Nunchuck with arduino and it works fine.

HW is 4.12 and FW is 2.18

really hope this will be solved sometime soon.


Return to “Feature Requests”

Who is online

Users browsing this forum: No registered users and 2 guests