Search found 10 matches

by Cristian
14 Oct 2017, 05:33
Forum: General
Topic: SPI or ABI?
Replies: 2
Views: 573

Re: SPI or ABI?

Thank you!
by Cristian
13 Oct 2017, 07:05
Forum: General
Topic: Hub motor + AS5047 + ring magnet
Replies: 0
Views: 307

Hub motor + AS5047 + ring magnet

Hi folks, I want to use the VESC to control hub motors which will have the axle coming out at both ends so there is no way to attach the small magnet that comes with the AS5047 encoder So I was wondering how can I overcome it and thought of attaching a ring magnet to the motor and put the encoder cl...
by Cristian
22 Sep 2017, 00:31
Forum: General
Topic: SPI or ABI?
Replies: 2
Views: 573

SPI or ABI?

Which one is more resilient to noise?
I have 4 VESCs + 4 motors + 4 AS5047 encoders quite close together and I'm trying to decide which is the best way to get the signal from the encoders to the VESCs

Thanks a lot!
by Cristian
15 Sep 2017, 22:36
Forum: General
Topic: Java client library
Replies: 0
Views: 263

Java client library

Hi,

Is there a Java client that I can use to talk to the VESC?
I'm interested in pretty much a light version like sending commands and getting status, without all the configuration parts
I want to connect to it from Raspberry Pi 3 over UART or USB like BLDC-Tool does

Thanks a lot,
Cristian
by Cristian
14 Sep 2017, 06:14
Forum: FOC
Topic: Motor doesn't spin, only squeaks (FOC with encoder)
Replies: 13
Views: 922

Re: Motor doesn't spin, only squeaks (FOC with encoder)

So I removed the capacitors and the resistors and now it works! What was weird before was that when running the detection for the encoder multiple times the offset was always different...pretty much random but now it is the same every time (with some margin for error ofc) Thank you all for your help!
by Cristian
13 Sep 2017, 14:05
Forum: FOC
Topic: Motor doesn't spin, only squeaks (FOC with encoder)
Replies: 13
Views: 922

Re: Motor doesn't spin, only squeaks (FOC with encoder)

I did try all the control modes and the behavior is the same, it looks like it tries to turn but it just squeaks I did not replace resistors or remove capacitors, I was thinking about that but the rotor position looks so good I thought it's not needed for ABI Power lines are 3in/8cm away from encode...
by Cristian
13 Sep 2017, 11:21
Forum: FOC
Topic: Motor doesn't spin, only squeaks (FOC with encoder)
Replies: 13
Views: 922

Re: Motor doesn't spin, only squeaks (FOC with encoder)

FOC tab looks like this foc.jpg The motor is the 190kv version of this http://diyelectricskateboard.com/diy-electric-skateboard-kits-parts/electric-skateboard-motor-5055-260kv/ , I hope it's ok to post links like this One detail I forgot to mention is that while I was trying to get Position Control ...
by Cristian
13 Sep 2017, 03:01
Forum: FOC
Topic: Motor doesn't spin, only squeaks (FOC with encoder)
Replies: 13
Views: 922

Motor doesn't spin, only squeaks (FOC with encoder)

Hi all, I'm trying to use the VESC for a robotics project, my main use cases are position control and RPM control (need high torque at low RPM) I'm using brushless motors with AS5047P encoder in ABI mode What I did so far: - configured currents and voltages (6S battery) and FOC mode in Motor tab - s...
by Cristian
06 Jul 2017, 14:54
Forum: General
Topic: 4 VESCs controlled by a Raspberry Pi 3 over I2C or USB
Replies: 3
Views: 1183

Re: 4 VESCs controlled by a Raspberry Pi 3 over I2C or USB

Thank you!
Does this mean I can still control them independently ? (my assumption was that the slave/s will do exactly what the master does, for the dual motor board scenario) but you gave me hope that I might be able to control them independently :)
by Cristian
06 Jul 2017, 00:47
Forum: General
Topic: 4 VESCs controlled by a Raspberry Pi 3 over I2C or USB
Replies: 3
Views: 1183

4 VESCs controlled by a Raspberry Pi 3 over I2C or USB

Hi guys, I just joined the forums looking for a little help to get started. I want to control 4 VESCs from a Raspberry Pi 3 over I2C preferably. I searched and there are expansion boards to add CAN to the Pi but that would unnecessarily complicate my design. UART is out of the question as the Pi onl...

Go to advanced search